No announcement yet.

new build - fireEvent from EXNABVAL

  • Filter
  • Time
  • Show
Clear All
new posts

  • new build - fireEvent from EXNABVAL

    I can't seem to get this to work. I can see the fireEvent in DevTools, but it still seems like the Edit Grid continues doing it's thing whether it's an update or an error.

    If I leave success:true, it just does the update..... if I set success:false then it seems to pop an empty nabMsg window.... I tried outStopProcess=*on too but no luck.....

    Feels like I'm missing a step.....


  • #2
    Are you attempting to abort the add/update in this case? What type of actions are tied to your they appear to be executing?


    • #3
      the fire occurs when the user enters an invalid code...... so I'm trying to launch an app that allows them to select from a list of valid codes..... nothing seems to be happening...i added a snackbar message to test but that doesn't happen either...


      • #4
        We have not been able to replicate this issue. Anytime we fire an event from an EXNABVAL based program the event actions execute (assuming we are listening for that event).

        Are there any other details we might be missing?


        • #5
          i'll keep playing with it.... I'm wondering if my NABVAL has an issue...i'm seeing other oddities as I try to get Local Data to work....same basic theme though --- DevTools indicates all is good but the app doesn't reflect what DevTools indicates....

          stay tuned.....


          • #6
            not sure what else i can do.... I've deleted and recreated the fireEvent typing in the event name, cut/pasting the event name.... nothing works.... the attached image shows DevTools and the underlying app popping up the appropriate error so I believe everything is working --- but the listener doesn't react.....for this last test, I removed the launch that I'm ultimately trying to add.... I'm just putting a message to the snackbar...

            The other oddity related to Local Data has me stumped as well....DevTools shows me the applyData with the correct data that I sent back to the app, yet the screen does not reflect the "D" at the start of "Dan".... I've tried this with SetValue and SetResponse.... same result...



            • #7
              Following up on this post; Found that the edit grid when set to inline editing for row/cell was not listening for backend events;

              This will be updated in our next Valence 6.0 build


              • #8
                looks good so far... thanx