No announcement yet.

New Chrome browser update broke grid data bind in one app

  • Filter
  • Time
  • Show
Clear All
new posts

  • New Chrome browser update broke grid data bind in one app

    Google Chrome is up to date
    Version 84.0.4147.89 (Official Build) (64-bit)

    I'm not understanding this at all. This release updated last night, I had the "Whats New" tab in the debugger. This is a dashboard app using your old FusionCharts approach, so it is not an MVC app, uses the old school On Ready.

    The FusionCharts work fine, I have some ordinary grids that are the problem. The grid renders, just no data appears in the grid. The debugger shows the data being sent correctly, no errors appear anywhere. Well, except the normal one where theme can't find none.png, which has never caused a problem.

    The reason I know it is the Chrome update is because this worked yesterday and it still works fine in IE Edge browser (old Edge, not new Chromium based).

    The strange thing is, only this one app using non MVC grid broke, all the rest I've checked still work fine. The only difference I see is the number of grids, this broken app has 6 different grids, all rendering with no data. I tried scaling back to rendering only one of them, does not fix. I've seen some strange stuff in this world but this one takes the cake.

    So what the heck do I do, just hope Google fixes whatever the heck they just did?

  • #2
    OK, update here. It clearly is some CSS problem, not a grid binding issue. I have 6 grids that show downtime information, one that shows some other information. The one was still working, just the downtime ones that were not. Programmed identical.

    So on a lark, I swapped positions of one of downtime and the other. Then the downtime displayed the data and the other did not.

    Looking deeper now that I know this.


    • #3
      This is not fixable. I've seen this before from Google with FusionCharts on a dashboard. In that case, if widgets were not on the web page you can see without scrolling down, they did not render. That eventually magically fixed itself.

      In this case, the FusionChart widgets not visible are rendering, it's just the grids that aren't. But if I move grid higher on page, it works fine. But that doesn't help.:mad:

      Nothing anybody reading this can help with though, I assume Google will fix eventually like last time.


      • #4
        Hi Terry -

        We just had another customer experiencing the same issue. His issue has since been resolved after installing the latest Windows 10 update.


        • #5
          Hi Sean. Strange, it still works in Edge. You'd think if o/s issue it wouldn't work in any browser. But who knows. Corp uses WSUS to push Windows updates so not something I can really trigger to test the theory.

          I'm at 1909 build 18363.592. I do have a Surface at home which I'm in control and is getting direct updates. I'll test that theory on that machine. Thanks!

          ps I did use debugger to inspect the CSS in one of grids. You can tell the binding working, you can see there is rows in grid. You just can't see the data values. Very strange.


          • #6
            Sean, I just saw this in CNX Tips email.

            Earlier this week an update released for the Chromium browser engine, which powers popular browsers Chrome and Edge, caused a rendering bug in grids. Specifically, the update (84.0.4147.89) occasionally causes grids to show no rows, a bug that is apparently triggered only when a border radius is applied to the grid. As a workaround to this problem, in the latest Valence 5.2+ build (5.2.20200720.1) we've temporarily adjusted the NAB runner to ignore border radius overrides. We will reinstate the border radius logic once the issue is corrected in a future Chromium update.

            Note that if you've created your own apps outside of NAB using Ext JS grids you may need to adjust your code accordingly. Alternatively, you can have your users use one of the browsers that do not use Chromium (Safari, IE, Firefox, etc), as these browsers do not exhibit this rendering problem

            I'm not overriding your core CSS to format grid in any way. And in my case, only when the grids are in the Center section of Border layout does this bug show up. If I move same grid to the North section, it then works fine. I experimented with using another layout besides Border but does not fix. Any of grids rendered in section of page that needs to scroll shows no data in the rows. Strangely, the first grid actually fits on page before scrolling but it has same problem. But if I move that grid up on page, it works.

            I've included code to this monstrosity if you or anyone wants to look. But I'm still not clear on action step here. I'll certainly update your new maint release when I can and see what that does.
            Attached Files


            • #7
              This is a layout issue, period. The viewport using Card layout. My initial effort was to assign the panel with setActiveItem to the viewport. The panel had a Border layout. I’ve just done the following tests:
              1. Changed the panel to Window, did not assign to viewport. It then behaved exactly like IE Edge, when data loads the column headers/toolbar disappear. When viewport in Chrome, entire grid does not show.
              2. Changed the panel layout to Auto. It then works perfectly in both Chrome and Edge. I also tested as Window with Auto, works perfect.
              3. Changed layout on panel to VBox. In Chrome, both on viewport and Window approach, you get toolbar of panel and none of grids show. That’s with a minHeight and flex specified for each grid. I didn’t check IE.
              4. Changed layout to HBox, same minHeight and flex config as VBox. Works perfectly on Viewport in Chrome and IE. I did not test Window, sure it works also. That does not seem to be factor.

              The original dashboard that failed (and is still in that condition) was a Border layout on viewport. So no question this some kind of CSS rendering problem.