Announcement

Collapse
No announcement yet.

Fusion5250 - 5.2.20200212.0 WebSocket Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fusion5250 - 5.2.20200212.0 WebSocket Error

    Good morning,

    We loaded the latest update to Valence 5.2+ 5.2.20200212.0. We are running the base in VALENCE52 and a production instance using SSL in VALENCE52P. I used your instructions in your documentation to configure the SSL for VALENCE52P instance. Initially, I tested the application in our Base Instance VALENCE52 (No SSL). The base instance worked. After configuring the production SSL instance, when I start the production SSL app, then it then says "The port number "17052" might already be in use....

    Do I have to use a different port number on the Production instance or do I need to change something?
    Valence Fusion Web Socket Error.JPG ?

  • #2
    Are you configuring Fusion5250 with SSL in the VALENCE52P instance for the first time now, or was this something that was working before and now just stopped working after you applied the latest Valence update?

    Comment


    • #3
      We had an older version of the portal that didn't support SSL previously. This is our first attempt with using SSL. Do you think I have to have our managed service provider for our i-series open port: 17052 in the firewall? I noticed that the base instance seemed to have an issue when I started the SSL instance. Do those need to use separate ports?

      Comment


      • #4
        The VALENCE52P port is probably conflicting with the port assignment in the VALENCE52 instance. In VALENCE52P, go to Portal Admin-->Settings and scroll down to the Fusion5250 Settings area. There's you'll see a value for "Socket Listener Port". That value should be the same as the instance port except with a 1 in front of it. For example, if your VALENCE52P instance port is 8052, then the Fusion5250 Socket Listener Port for that instance should be 18052. If you change the port, make sure you stop and start the instance fully, including making sure all Fusion5250 jobs are ended for VALENCE52P (you might need to do that by manually ending some of the jobs) before you restart. Follow the SSL instructions carefully. As far as opening a port on the network, it depends on how your network is set up and from where users are accessing. If it still doesn't work after these changes then talk with your network engineer to make sure the port is open.

        Comment


        • #5
          Thanks for the response. I changed VALENCE52P to use port 18052 since the instance is using port 8052. I am waiting on my provider to make sure that port is also open. I will update you once that has been checked off.

          Comment


          • #6
            Our manged provider opened both ports 17052 and 18052. I stopped and started the instance as you recommended. I am still getting the error shown below (note new port). Our Base instance is working on port 17052.

            Error communicating with wss://mynocs.nocs.com:18052. The port number might already be in use, the VVFUSIOND/P jobs on IBM i may not be started, or there could be a firewall blocking communications.

            On our Base Instance in the browser [Network] tab I can see vvvport.pgmOn our Production Instance I see mynocs.nocs.com (instead of vvport.pgm)
            Error in connection establishment: net::ERR_CONNECTION_CLOSED

            Let me know how to proceed?

            Comment


            • #7
              I used an open port check tool to verify that port 18052 is open. What else can I check?
              I checked "Digital Certificate Manager" and I verified my setup. Digital Certificate Manager shows the "Portal Cert" is assigned to both VALENCE52P and Valence Fusion.

              Comment


              • #8
                Perhaps we should take a look at your setup via a web meeting. Give us a call on the support line and we'll see what we can sort out.

                Comment


                • #9
                  I called a couple of times and your lines are busy. You can email me a link to web meeting or call my cell phone (337-849-3179).

                  Comment


                  • #10
                    Was this today that you are calling and the number is busy? If so what number were you dialing?

                    Comment


                    • #11
                      Good morning,

                      The updates to the IFS permissions on the Certificates two days ago worked and the product is working well. We have quite a few folks working from home so this product solved a quick problem where a VPN connection wasn't required. Thanks for your help!

                      Comment

                      Working...
                      X