Announcement

Collapse
No announcement yet.

Internal Server Error on vvOut_toSS after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • robert.swanson
    replied
    Hi Edward,

    Your Instance Manager in 5.0 won't show 5.2 instances, as the Instance Manager app is specific to the core version (5.0, 5.1, 5.2, 6.0).

    So you would need to log into your base VALENCE52 instance -- presumably on port 7052 -- to see 5.2.20200720 running. Then you can use that 5.2 version of Instance Manager to create new 5.2 instance(s) (i.e., VALENCE52P), after which you would use VVMIGRATE to copy over your 5.0 instance(s) to the corresponding 5.2 instance(s).

    The latest build for 5.2 is 5.2.20201209.0, so before you set up any new 5.2 instances I would recommend you download and install that, if you haven't already.

    Leave a comment:


  • edward.thomas
    replied
    That download does work but not as expected. After about a minute it produces what seems to be a data definition dump, a couple of Conversion Errors and lots of 'Workbook not initialized' errors.

    However the download does work well with v5.2.20200720 so this is the route. Curiously this version is not appearing in our Instance Manager. Do you know how I can remedy this or should I reinstall? If I reinstall I will go to the latest 5.2.

    Leave a comment:


  • robert.swanson
    replied
    I suspect VVOUT may be having some sort of trouble unzipping the xlsx template file, which occurs upstream of those exception messages.

    Can you try going into Portal Admin > Users and see if you can download a spreadsheet from that?

    Assuming that does not work either, which is what I would expect, I would suggest you try downloading a more recent version of Valence (either 5.2+ or, preferably, 6.0) and try the same Portal Admin > Users download to confirm it works.

    Based on the results of that we can decide the best path forward for you. If upgrading isn't an option, perhaps we could import some of the updates from 5.2+/6.0 into your old 5.0 version of VVOUT.

    Leave a comment:


  • edward.thomas
    replied
    Yes two errors.

    Program: VVSRVPGM Statement:
    Module: VVIFS Message ID: 3490
    Procedure:
    VVIFS_OPENFILE
    Message Text:
    Conversion error.
    Help Text:
    The path to the file is /valencedev/temp/112513/xl/_rels/workbook.xml.rels
    Calling Program:
    VVSRVPGM
    Call Stack:
    VVCALL[VVCALL]-->CS020VL[CS020VL]-->VVSRVPGM{VVOUT}[VVOUT_TOSS]-->VVSRVPGM{VVOUT}[VVOUT_SSDSROWS]-->VVSRVPGM{VVOUT}[VVOUT_SSOPENWORKSHEET]-->VVSRVPGM{VVOUT}[VVOUT_XLSXOPENWORKSHEET]-->VVSRVPGM{VVIFS}[VVIFS_OPENFILE]


    Program: VVSRVPGM Statement:
    Module: VVOUT Message ID: VV9999
    Procedure:
    VVOUT_XLSXOpenWorksheet
    Message Text:
    Can not open template workbook.xml.rels
    Help Text:
    The Workbook relationship file not found
    Calling Program:
    VVSRVPGM
    Call Stack:
    VVCALL[VVCALL]-->CS020VL[CS020VL]-->VVSRVPGM{VVOUT}[VVOUT_TOSS]-->VVSRVPGM{VVOUT}[VVOUT_SSDSROWS]-->VVSRVPGM{VVOUT}[VVOUT_SSOPENWORKSHEET]-->VVSRVPGM{VVOUT}[VVOUT_XLSXOPENWORKSHEET]

    Leave a comment:


  • robert.swanson
    replied
    Hi Edward,

    Hard to fathom why an OS upgrade would impact that particular procedure. Do you see any pertinent messages in the Errors app?

    Leave a comment:


  • Internal Server Error on vvOut_toSS after upgrade

    We are at Valence 5.0.2 and on upgrading to V7R4M0 we get an Internal Server Error with vvOut_toSS. Is there anything we can recompile to get this working?
Working...
X